Microsoft Project for Industrial Asset Managers

[Sample]
Introduction
Maintenance projects are exceedingly dynamic, and as such require a level of updating and retooling that would appear absurd in any other project management application area. It would not be unusual to see a turnaround plan, for example, significantly reworked every eight hours. As such, it takes an usual depth of familiarity and facility with the project management software employed.  While nothing can replace the value of experience, a thorough foundation provided by systematic training can advance your abilities in Microsoft Project by leaps and bounds, as well as provide access to aspects of Microsoft Project that your organization may have overlooked.

This text serves as a companion to just such a training. In its pages you will find valuable references, diagrams, and outlines that will help you follow along in the course and reinforce what you have learned.
After completing New Standard Institute’s Microsoft Project for Maintenance course, you will be well-practiced in using Microsoft Project’s interface, have a very clear idea of what it can and cannot do for you, and will be expert at customizing it to tailor to your needs. You will be able to:

· Understand the abilities and limitations of Microsoft Project
· Understand the logic of Microsoft Project, to build robust projects and quickly troubleshoot them

· Create a readable, thorough, and precise Project file
· Build quality control and safety plans into your project

· Make the most of automatic and semi-automatic tools to save you time: import work data from Excel, collaborate and collect information, and automatically distribute reports
· Use Microsoft project to most effectively manage your projects

· Make reports available in the appropriate detail to the appropriate stakeholders, with minimal effort

· Configure and customize Microsoft Project to suit maintenance work, your organization, and you

· Quickly optimize your project, so that changes can be managed daily

PMBOK XE "PMBOK" 
This seminar was designed with the framework of the Project Management Institute’s XE "Project Management Institute"  Project Management Body of Knowledge XE "Project Management Body of Knowledge"  (PMBOK) in mind. This framework defines a structure of terminology, relationships, tools, and techniques that encompass project management activities. A little background in PMBOK concepts and terminology will help facilitate an understanding of this course.

According to A Guide to the Project Management Body of Knowledge: PMBOK Guide, project processes XE "Project Process"  can be collected into five groups. Quoting from the PMBOK Guide:
· “Initiating Process Group XE "Project Process:Initiating Process Group" . Defines and authorizes the project…
· Planning Process Group XE " Project Process:Planning Process Group" . Defines and refines objectives, and plans the course of action required to attain the objectives and scope that the project was undertaken to address.
· Executing Process Group XE " Project Process:Executing Process Group" . Integrates people and other resources to carry out the project management plan for the project.
· Monitoring and Controlling Process Group XE " Project Process:Monitoring and Controlling Process Group" . Regularly measures and monitors progress to identify variances from the project management plan so that corrective action can be taken when necessary to meet project objectives.
· Closing Process Group XE " Project Process:Closing Process Group" . Formalizes acceptance of the product, service or result and brings the project… to an orderly end.”
Microsoft Project’s strengths play primarily to the middle three groups: planning, executing, and monitoring. Its reporting and archiving features also assist significantly with the Closing Process Group.
It is important to reinforce that planning and executing are not a sequential activity, as you might expect. Planning continues to progress during execution, to account for any changes that may have occurred. As was noted earlier, maintenance work involves a large number of changes, and so this is particularly true for our purposes.
We will also talk from time to time of project stakeholders XE "stakeholders"  – those with a vested interest in the outcome of the project. 
Basic Microsoft Project
Don’t be intimidated by the array of functions available in Microsoft Project – in this section we will draw your focus to those aspects that are most fundamental to maintenance work. After completion, you will be able to describe the basic structure of Microsoft Project, will have walked through an entire project, and will begin to understand the logic of Microsoft Project. 
Project Structure XE "Project Structure" 
Project consists of essentially three components:

· Planning XE "Planning"  tools
· Tracking XE "Tracking"  and executing tools
· Reporting XE "Reporting"  tools


With respect to Microsoft Project, your task as project manager is to create resources XE "resources"  (workers, equipment, and materials), assign them to tasks XE "tasks"  (elements of work, usually part of a larger job), manage communications and tracking XE "tracking"  (updating tasks during execution with progress information), and generate reports.

Underlying these components are three different types of data:

· Task data - pertains to an element of work;

· Resource data - pertains to workers, equipment, or material;

· Assignment XE "Assignment"  data - pertains to the conjunction of a resource and a task.
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An assignment is different from a task in that it is a particular resource assigned to a task – many assignments can take place on a single task, and one resource can have many assignments during the course of a project. A resource may even have several assignments simultaneously, although multiple, simultaneous assignment of a single resource isn’t considered good practice in the maintenance context.
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Incidentally, in this text and throughout the seminar we will use the word task and activity interchangeably to refer to the Microsoft Project program element named above. The group of tasks that pertain to a single work order are referred to as a job – sometimes there will only be one task on a job, but typically there are dozens.

Each data type – task, resource, and assignment – has it’s own fields XE "fields"  (containers for categories of information; examples of fields include Duration, Actual Start, Name, Work, etc.. Some fields are automatically calculated, while others are entered by the user. Some fields are timephased XE "timephased" , meaning they can be changed on a minute-by-minute basis. More on this later). For example, resources and tasks both have a field called Name, although they are not in fact the same field. Assignments and tasks both have a field called Cost, but the task Cost field can be entered by the user, while the assignment Cost field cannot, as it is calculated by Microsoft Project.
Microsoft Project includes capabilities to create custom fields XE "custom fields"  – user definable fields that can store from ten to thirty different cost, date, duration, finish, flag, number, start, and text values each for tasks and resources. Remember: if you set up a text1 field for tasks it will not be the same as the text1 field for resources!
A simple yet valuable distinction exists between elapsed time XE "elapsed time"  and working time XE "working time" . As you might expect, elapsed time is time according to the calendar – there are seven days in a week, four hours between midnight and 4AM, etc. Working time, however, is the time that passes while people are working; Microsoft Project is set up so that, while 24 hours of elapsed time occur between Tuesday 4AM and Wednesday 4AM, only 8 hours of working time pass. By default, there are zero hours of working time during the 48 hours of elapsed time between 11PM Friday and 11PM Sunday, due to the weekend.  These values can and should be customized to suit your organization’s working style.
Since Microsoft Project is designed to work during initial planning through execution, replanning, and reporting, there is a need to record several projects, so to speak. These projects are stored in the set of fields that pertain to each task – duration, start, resources, cost, etc.
· the “original” project, generally completely planned before the start of the execution phase, is saved as the baseline XE "baseline" .  For example, Task A may be originally planned to start at 8AM and end at 10AM, so the Baseline Duration field has a value 2 hours;

· Actual XE "Actual"  values represent the project as it occurred. If Task A started at 8AM and finished at 11AM, then the Actual Start field is 8AM, Actual Finish field 11AM, and Actual Duration is the (working) time in between, or 3 hours;
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Scheduled XE "Scheduled"  – if a task has started, then the scheduled value is the actual value; if it hasn’t started, then the scheduled value is the value according to the current plan, which likely has changed from the baseline due to overdue tasks, late starts, etc. For example, it is now 2PM and Task A started at 1PM. It is now scheduled to finish at 3PM, for a scheduled duration of 2 hours.  Find the scheduled values in the unaltered field names – Duration, Start, Resource Names, etc. are all fields as scheduled.  Remember that the scheduled values become the actual values once actuals are reported.
Working with Project
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Microsoft Project has several completely different and indispensable views XE "views" , each of which take advantage of different tables XE "tables" .  These views are used variously for entering general data, entering very specific data, viewing data, and analyzing data. The tables are grids where information stored in fields is directly accessible. A table consists of nothing more than a list of fields to be displayed – they can be changed by accessing Menu>View>Table… and selecting from the pull down list. With the exception of Calendars and a few other features, all of the data that is in your project is accessible in Resource tables, Task tables, and Assignment tables – each type of table can only access fields of that data type. Importantly, you can insert fields XE "insert fields"  of your choice into any table by right-clicking on a table column heading and selecting Insert Column…., or left clicking on the column and hitting the Ins button, or by clicking anywhere in the table and accessing Menu>Insert>Column…. There are dialog boxes and other places where data can be entered in a form, but it is often far more convenient to simply look up the name of the field you are interested in (they are always provided within this text) and insert it into the relevant table for editing or viewing.  You can also select from many pre-configured tables by clicking Menu>View>Table:> and selecting from the list. If you find yourself inserting the same fields often, you can create a new table to save in the project by clicking Menu>View>Table:>More Tables… and hitting the ‘New’ button. 
Each view generally contains tables or information on only one data type: task, resource, or assignment. The main views of this type are: Gantt Chart, Tracking Gantt, Resource Graph, and Resource Sheet. The two views that combine task, assignment, and resource data are the Resource Usage view and the Task Usage view, which will be discussed later. For now familiarize yourself with the Resource Sheet, Gantt chart, and the View Bar, which is convenient for switching between views.
Build a Basic Project
After completing this section you will be able to perform all of the steps necessary to build and execute a basic µ from beginning to end, from entering resources, setting up tasks, and performing resource load leveling, to updating, tracking, and reporting performance.  Exercises designed to reinforce concepts learned in class and in this text will also build familiarity with the Microsoft Project interface.

We will touch on the following key concepts: 
· the importance of completely and accurately creating tasks and resources;
· how to set up your project for optimal load leveling;
· how to properly navigate the complex functionality of Microsoft Project;
· the importance of tracking;
· reporting Earned Value statistics.

Basic Resource Entry

Resource records act as containers for many types of information related to workers, equipment, and materials. Include as resources all limited human and equipment resources, especially high-tech testing tools, cranes, and other equipment that may be unique or of limited number. For costing and procurement purposes, it can be useful to enter consumable materials as well. For example, you might want to keep track of worker’s vacation schedules, so that you don’t mistakenly schedule them to work when they are on holiday.  You can enter different (even variable) pay rates for different workers, and use this information to calculate the total cost of the project. By gathering information about performance according to each resource, you can track contractor value and use the information to guide future procurement decisions.
One of the most powerful tools that project management software provides is called load leveling.  Load leveling alerts you to resource overallocation by noting when a resource is assigned to more than one minute’s worth of work in any one-minute period. XE "overallocation" 
The basic view giving access to tables with resource fields is the Resource Sheet. Key fields:

	Field
	Description
	Used for:

	Name
	Name of the resource
	Referencing the resource

	Std. Rate XE "Std. Rate" 
	Rate used in calculations for work indicated as normal hours
	Baseline, actual, and scheduled costs calculations

	Ovt. Rate XE "Ovt. Rate" 
	Rate used in calculations for worked indicated as overtime hours
	Baseline, actual, and scheduled costs calculations

	Generic XE "Generic" 
	Indicates that the resource is a fake placeholder that later will be replaced with a ‘real’ Microsoft Project resource
	Staffing procedures, discussed in later chapters


Use the Resource Information dialog box to access the complete Availability XE "Availability"  information. Availability information allows you to set the dates that a resource can work on a project. It is important that you set up availability to match a resource’s actual availability schedule, to avoid assigning them to tasks when they are not in fact available to work.

The Resource Information dialog box can also be used to gain form-style access to other common resource fields, to be discussed later.

Basic Task Entry

Microsoft Project’s strength relies on a simple concept called work breakdown XE "work breakdown"  – the repeated reduction of a job into its component activities, together with a link indicating the order the activities are to be performed in. The graphical representation of this work breakdown is called the project network XE "project network" . Generally tasks are reduced to different levels of complexity – “replace all bulbs in building B07” could require thousands of steps, but not benefit from further breakdown. However, a job with many resources – people, equipment, and materials - working under different supervisors and for differing durations, will likely benefit from a significant degree of work breakdown, even though all the activities take place on the same work order. 

Why go to all the trouble of performing an adequate work breakdown? It can be a painstaking process to enter all of your turnaround work data into a Microsoft Project. When it comes to making a rough estimate of the cost and total duration of a turnaround, there are clearly easier and faster alternatives - for instance, you might use data from previous turnarounds, perhaps with a corrective factor to account for plant maintenance improvements or undue deterioration. Ask yourself, however, if there is any alternative besides laying out the project and scrutinizing it on a task by task basis that allows you to truly maximize the use of project resources and minimize the duration of the project. By experimenting with different scheduling arrangements you can optimize resource utilization and project duration while eliminating plans that result in unnecessary inefficiencies and duration. Many departments opt not to execute a work breakdown, and simply plan each work order as a bulk job with no internal scheduling features, sidestepping the optimizing process.  Not only do these projects miss out on key efficiencies that can be achieved with a detailed work breakdown, but they also forego tracking and reporting features and the benefits therein, improved project control, quality and safety checks, and budget and time estimates.
Creating tasks is a little more complicated than creating a list of resources, since work breakdown must proceed up to a certain depth and logical predecessor relationships must be properly set up. Generally, you should reduce your jobs to a level of detail that corresponds to the different resources used on the job – if only one resource is used on the whole job, go ahead and leave the job as a single task. Logical relationships should be included only when the job makes it logically necessary - shoes go on before pants by necessity, so that logical relationship would be built in to the project. However, you might take out the trash before you vacuum the rug only because you can’t be in two places at once – these types of relationships should be resolved through a process known as load leveling or level delay, which is discussed in detail below.
Most Task entry takes place in the Gantt Chart view. Gantt Charts are a visualization tool that represent tasks as horizontal bars laid out on a timeline – their location and length indicate start dates and durations. Microsoft Project includes arrows to indicate logical predecessor links as well. The Gantt Chart XE "Gantt Chart"  view shows a task-data table on the left and a Gantt Chart on the right, which renders information from the task database. The calendar at the top of the Gantt chart indicates the representative time and dates, while bars stretching across these columns signify task durations. Again, the arrows linking tasks show predecessor relationships – the order in which tasks logically must be performed. 
You can use the insert column techniques discussed above to access any task field you like in the Gantt Chart view; alternately, access the Task Information XE "Task Information"  dialog box on the toolbar, by right-clicking a task, or by clicking Menu>Project>Task Information.

	Field
	Description
	Used for:

	Name
	Name of the task
	Referencing the task

	Start XE "Start"  and Finish XE "Finish" 
	Start and finish dates for the task
	Scheduling, duration, etc.

	Work XE "Work" 
	Labor hours involved on the task, calculated from resource assignments
	Cost estimating, rescheduling when adding resources

	Duration XE "Duration" 
	Working time between task start and task finish
	Baseline, actual, and scheduled duration calculations

	Resource
	List of resources assigned to the task
	Resource use calulations

	Constraint XE "Constraint" 
	Rules that determine the way Microsoft Project calculates the start of the task
	Task Start and Finish date calculations

	Predecessor
	The ID of the Task that must occur in order for the current task to begin
	Logical predecessor links, basic project network creation


For the moment, create your basic project network by filling in only those fields mentioned in the table above. You should see the Gantt Chart automatically update to reflect task information as you complete each task.

The ability to group tasks together under Summary Tasks is a very useful tool in larger projects, and it is a good idea to get into the habit of using them. You can roll subordinate tasks up into a Summary Task, clearing up the Gantt Chart a bit and making it easier to focus on the job at hand. They also summarize all of the duration, cost, and other information for the tasks contained within them – it is important, for this reason, not to assign any resources or costs to Summary Tasks – although Microsoft Project allows you to do this, it will greatly complicate reporting, and is not the intended function of the Summary Task.  You also want to avoid assigning predecessors to summary tasks – instead, link to tasks within the summary task. 
Summary Tasks are created by demoting and promoting tasks in a Task Table. Adjacent tasks that are on the same level in the heirarchy are grouped together under the first higher-level task above them, which becomes a Summary Task. Use the Indent button [image: image1.png]


 on the Formatting toolbar, or click Menu>Project>Outline>Indent, and the Outdent button  [image: image2.png]


 or Menu>Project>Outline>Outdent to move tasks higher and lower in the hierarchy.   
To properly set up a project network, follow these rules:

· Only include logical links that are made physically necessary by the job
· Perform a thorough work breakdown that allows truly independent tasks to be tracked and rearranged

· Don’t enter dates - only relationships and durations

· Assign all of the resources that are truly required for the job
· Don’t cut and paste tasks in the task table – this causes all kinds of problems!
· Group tasks pertaining to a single job under summary tasks, and for large jobs similar tasks or phases should be grouped under summary tasks as well

· Don’t assign costs or resources to Summary Tasks

· Use few entrance and exit points –  create milestones that represent the end of a job and link the final tasks in the job to it

Microsoft Project calculates the task Start and Finish dates according to constraints XE "constraints" : As Soon As Possible is the default, and the only one we’ll use for now. After setting up a multi-job project in this way, you will have an enormous amount of jobs that all happen concurrently, since you didn’t enter any dates and the only relationships you’ve set are those that are logically necessary. All of the job Start dates will be pushed to the Project Start Date XE "Project Start Date"  – a date you set which represents the beginning of the project, and which defaults to the date the project file is first created. In order to accommodate the fact that you don’t have an infinite number of workers, tools,  or space available to perform all of the tasks simultaneously, we perform load leveling.
Incidentally, set the Start Date by clicking Menu>Project>Project Information… 

Basic Leveling
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Load leveling XE "Load leveling" , or resource leveling XE "resource leveling" \t "See Load leveling" , is the procedure which fixes overallocations of workers and other resources. Recall that an overallocation XE "overallocation"  is, generally speaking, a situation in which a resource is assigned to too many tasks at the same time. We will present a much more precise definition later.

There are two ways to load level: manually, using analysis tools provided within Microsoft Project and manually delaying and splitting tasks; or automatically, using Microsoft Project’s load leveling algorithm. Here we’ll begin with manual load leveling XE "manual load leveling" , in order to understand the concepts behind it, then later we’ll move on to automatic load leveling.  Manual load leveling will continue to be a valuable tool, as Microsoft Project’s load leveling can make decisions that are undesirable.
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The first step in manual load leveling is identifying the overallocation; there are several ways to do this, but we’ll begin with the simplest. In the Resource Sheet view, overallocated resources are indicated with an exclamation point in the indicator column (the indicator column is the left-most column on all tables, and alerts you to any unusual situations that hold with that task, assignment, or resource) and red text. Another, more useful identifier is the Resource Graph, a histogram of the number of units XE "units"  of a resource that are assigned in a given time period.  (Units are an indicator of the quantity of a resource to be assigned to a task; workers, equipment, and most other resources in a turnaround will simply be refered to as 100% - overallocated resources will show up as 200% units of usage if they are on two tasks simultaneously, or 300% if they are on 3 tasks. More on this later.)
Next, overallocations need to be resolved by rearranging the schedule. This is achieved by introducing leveling delay and splits XE "leveling delay" . Leveling delay is nothing more than a delay that moves tasks in the schedule without introducing start constraints or unnecessary predecessor links. They are a way of indicating to Microsoft Project that this task has been put off while waiting for a resource to be freed up. In our household example, you would insert a leveling delay of 15 minutes into the task ‘vacuum the rug’ while you take out the trash. It is important not to use start constraints or unnecessary predecessor links because future changes in the schedule will necessitate further load leveling, which is made much more difficult when load leveling adjustments are buried in the project network together with actual date constraints and predecessor relationships. Splits interrupt a task in order to let resources work on a second task, and then later return to the first task when resource demands allow it.
To set up Microsoft Project views for manual leveling, follow this procedure:
1. Switch to Gantt Chart view

2. Click Menu>Window>Split
3. Click anywhere in the bottom split to activate it

4. Switch to Resource Graph view

5. Activate the Resource Management toolbar: right-click in toolbar area and select Resource Management, or Menu>View>Toolbars>Resource Management

6. Insert the Leveling Delay column into the task table of the Gantt Chart view

The Resource Graph shows the workload over time of a single resource at a time – scroll through the right side of the graph to move through time, and the left side of the graph to view different resources. Important: when the Resource Graph XE "Resource Graph"  is open together with any other task view in a window split, it will only show those resources on the tasks that are selected in the other window. To be able to scroll through all project resources, select all tasks by clicking on any column header in the task table. 
To perform manual leveling with the Gantt/Resource Graph method, follow these steps:

1. Identify which resources are overallocated in the Resource Sheet view

2. Scroll through the left-hand pane of the Resource Graph to view an overallocated resource

3. In the Gantt chart, identify which tasks are causing the overallocation. If you have a very large project, filter for tasks using the resource in question by hitting the funnel button on the Resource Management toolbar or click Menu>Project>Filtered for>Using Resource…. Also note that you can move between tasks that involve overallocations by hitting ALT+F5 or Go To Next Overallocation XE "Go To Next Overallocation"  button  [image: image3.png]


 on the Resource Management toolbar.
4. Rearrange the schedule to resolve the overallocation – do this only by inserting a leveling delay in the task table of the Gantt chart – do not drag the bars on the Gantt Chart, do not introduce new predecessor logical relationships, and do not put in constraint dates by typing a date into the Start field!
5. Repeat for the remaining resources – note that resolving some overallocations will likely cause other overallocations; this is a very iterative process.

When you perform these steps, notice the decisions that you are making – which task have you decided to delay? Could you use different resources to resolve the overallocation? How about performing the job in a different way? Keep these in mind when you consider performing manual vs. automatic load leveling.
Basic Tracking XE "Tracking" 
Continuous improvement, stakeholder satisfaction, and financial accounting are all clear reasons to track a project’s progress. Perhaps less obvious, but certainly no less important, is the ability to identify and apply pressure precisely to sensitive areas that are slipping from the project plan. Tracking gives you remarkably detailed insight into where your project is developing problems, allowing you to make much more efficient use of your management time.  Moreover, it is widely understood that turnarounds in particular change more and at a faster pace than other types of projects. Parts don’t show up on time, the condition of assets can only be guessed at, and the sheer number of contractors means that scheduling problems are bound to turn up. Rapid change is a sure way to make a turnaround plan completely obsolete fast, so it is crucial to keep the project plan current with frequent tracking updates. 
How often is frequent enough? For turnarounds or other critical projects, it is certainly necessary to update the project every shift.  Project updates must match the rate of project change as well as the degree to which it is referenced, and in a turnaround this is likely to be every shift. This is not as momentous a task as it might seem, as we will see, but it does require the appropriate attention and commitment.

Some key concepts in tracking:

Status Date XE "Status Date" : this is the date that Microsoft Project uses to represent today in various calculations, with Progress Bars, and in progress reports; you can manually set it to any other day. Set the Status Date in the Project Information dialog box (Menu>Project>Project Information…).
Actual values XE "Actual values" : values as they have occurred. For example, after a task is completed it might turn out to have had an Actual Duration of 4 hours.
Baseline values XE "Baseline values" : values as they were originally planned before the project began. For example, the original project plan might have called for a duration of 3 hours.
Scheduled values XE "Scheduled values" : values according to the current schedule, given any changes that have occurred since the project began, either through actuals that didn’t match the plan or intentional schedule rearrangements. For example, the scheduled start of a task will be pushed forward one hour when a predecessor task has an Actual Duration of one hour longer than its original value.
Remaining values XE "Remaining values" : how much of a value is left on a particular task. For example, when reporting on a task midway through, you specify when it started (Actual Start), how many hours have been worked on it (Actual Duration), and how many are left (Remaining Duration). This can be entered or calculated using Percent Complete values, described below.
Percent Complete XE "Percent Complete"  and Percent Work Complete XE "Percent Work Complete" : an alternate way to enter Actuals in the middle of a task – 50% Complete means that half of the total Duration has passed in working time since the start date, setting Actual Duration equal to Remaining Duration and one-half of Scheduled Duration; 50% Work Complete means that half of the total Work (in labor hours) has already been achieved, setting Actual Work equal to Remaining Work and one-half of Scheduled Work.  Imbalances in work load assignment over the course of the task can mean that these two updates work out differently.
Tracking operates by changing the values of Actual and Remaining fields, listed below, on a task-by-task basis. By comparing these with Baseline fields, progress reports can be derived. Actual values will also elicit changes in Scheduled values throughout the project, due to logical predecessor relationships.

Actual, Baseline, Scheduled, and Remaining fields exist for the following categories: Cost XE "Cost" , Duration XE "Duration" , Start XE "Start" , Finish XE "Finish" , Work XE "Work" , Overtime Cost XE "Overtime Cost" , and Overtime Work XE "Overtime Work" .
To prepare for tracking a project, you will want to make sure that you have a baseline XE "baseline"  plan saved (Menu>Tools>Tracking>Save Baseline…), enable the Tracking Toolbar XE "tracking toolbar"  (right-click on toolbar area and select ‘Tracking’, or Menu>View>Toolbars>Tracking), set the status date if necessary, and access the tracking fields (Actuals and Remainings and described above). To access the tracking fields, you can either insert them as columns in the task table or use the Update Tasks XE "Update Tasks"  dialog box. At this point you can enter any actuals you have gathered.

Basic Reporting

Microsoft Project comes with an array of preconfigured, automatically generated reports XE "reports" ; once you have accomplished the relatively difficult tasks of work breakdown, project network creation, and tracking, your reports are available at the touch of a button. For now we’ll look at the Earned Value report and discuss the various terms contained therein, and later we’ll move on to more advanced reports and, ultimately, creating custom reports.

Access the Earned Value XE "Earned Value"  report by clicking Menu>View>Reports… Costs…Earned Value. Along the top of this report you’ll notice headers specifying ID, Task Name, BCWS XE "BCWS" , BCWP XE "BCWP" , ACWP XE "ACWP" , SV XE "SV" , and CV XE "CV"  columns. The first two are exactly what they appear, tasks identifiers. The next five are fairly simple concepts, but require a bit of fleshing out in order to properly define. 

BCWS XE "BCWS"  stands for Baseline Cost of Work Scheduled XE "Baseline Cost of Work Scheduled" \t "See BCWS" , and is sometimes called Planned Value XE "Planned Value" \t "See BCWS" . BCWS is the cost of the work on a particular task that, according to the baseline, was supposed to have been performed up to the status date.  It is the baseline (planned) cost to date for any given task. Microsoft Project calculates this by adding up all of the timephased cost values from the baseline start of the task to the status date. For example, the Baseline Start for a task is Monday, Baseline Finish is Thursday, and Baseline Cost is $100 per day. If the Status Date is Tuesday (which means all days up to and including Tuesday are included in the past), then BCWS is $200, even if work hasn’t even started on the task due to delays.

In this example, the Cost Variance (CV = BCWP - ACWP) is zero, since the work that did get done cost as much as it should have.  If it had cost more to do 25% of the work, the CV would be negative, indicating that the task is overbudget.

Schedule Variance (SV = BCWP – BCWS), however, is negative $100, since the task is behind schedule by $100 worth of work.  Even if it had cost more to do that 25% of work, the SV would be -$100.

BCWP XE "BCWP"  stands for Baseline Cost of Work Performed XE "Baseline Cost of Work Performed" \t "See BCWP" . BCWP is sometimes called Earned Value XE "Earned Value" \t "See BCWP" , and it is the most slippery of these three concepts. Each task has a total cost, and a total amount of work. When updates reflect that a percentage of the task’s work has been completed, Microsoft Project multiplies that percentage by the total baseline cost of the task and comes up with the BCWP or Earned Value. For example, a roofing job might be valued at $10,000. If you have completed half of the job, then you have earned $5,000 worth of BCWP – you have earned $5,000 worth of work, even if it actually only cost you $1,000 worth of labor to complete. Fundamental to this concept is the idea that you assign a worth to a task in the form of the original baseline cost – then any fraction of this work that is complete corresponds to a fraction of the worth of the task that has been earned. Microsoft Project calculates this value by multiplying the % Work Complete Field by the Baseline Cost Field. To extend the example from the BCWP, if by Tuesday the % Work Complete is 75%, then you have earned three-quarters of a $500 job, for a BCWP of $375. Note that it is % Work Complete, and not % Complete, that factors into the BCWP calculation, even though % Complete is used in the Update Tasks dialog box.
ACWP XE "ACWP"  stands for Actual Cost of Work Performed XE "Actual Cost of Work Performed" \t "See ACWP"  – this is simply how much money has been spent performing the task so far. It is always the same as Actual Cost, and sometimes is referred to as AC XE "AC" \t "See ACWP" .
You can infer performance from these parameters – if you have more Earned Value (BCWP) than you planned for (BCWS), then you are ahead of schedule. The term Schedule Variance XE "Schedule Variance" \t "See SV"  (SV XE "SV" ) accounts for this idea: it is defined as BCWP – BCWS.  Negative Schedule Variance means you are behind schedule, since you haven’t achieved or earned as much in Earned Value (BCWP) than you had originally scheduled (BCWS) in the baseline. 
However, if you are actually spending (ACWP) more than you planned (BCWP), given the amount of work you’ve accomplished, you are overbudget. Thus we have Cost Variance XE "Cost Variance" \t "See CV"  (CV XE "CV" ), equal to BCWP – ACWP. Negative Cost Variance means you are overbudget, as actual costs are higher than planned costs.
Set the Defaults XE "Defaults" 
Maintenance work has particular characteristics and requirements that need to be addressed when setting up the software.  These are listed and described below.
Menu>Tools>Options XE "Tools>Options" >Schedule…

Duration is entered in hours, to accommodate many short projects per day.

Uncheck effort driven; effort driven tasks are described below.

Menu>Tools>Options>Calculate…

Make sure that Calculation mode is set to ‘automatic’

Menu>Tools>Options>Calendar…
Hours per day (we’ll call this number ‘X’ for reference) is the number that Project uses to translate anywhere it uses the word ‘day’; ‘day’ always actually means ‘X hours’. If X = 10 and your task is 40 hours duration, Project would display its duration in days as 4 days. If X were 8 it would display 5 days. This can be confusing if resources can work multiple shifts or shifts that are longer than X hours. However, we generally eliminate the display of ‘days’, leaving everything in hours

Menu>Tools>Options>Interface…

Uncheck ‘Display Project Guide’ – screen space is at a premium in Microsoft Project.

Menu>Project>Project Information XE "Tools>Change Working Time" …
Set the calendar to a 24 hour calendar.
Note that there are four types of calendars: Base Calendars XE "Base Calendar"  (these are templates for use throughout the project), Resource Calendars XE "Resource Calendar"  (these, together with Resource Availability XE "Availability" , are the hours and dates that the resource can work),  Task Calendars XE "Task Calendar"  (these are the hours and dates that work on a task can be scheduled), and the Project Calendar (the default task calendar).
Review

At this point you should be familiar with the basic layout of Microsoft Project: what the major functions of Microsoft Project are, the way that they interact with each other, and the role that they play in project management. You have a sense of what rules to follow when laying the foundations for your project, and you are able to navigate the interface.  You are beginning to get a sense of Microsoft Project’s abilities and its limitations.[image: image4.png]


[image: image5.png]


[image: image6.png]


[image: image7.png]


[image: image8.png]















White dates on the calendar have working times according to the Standard Base Calendar; grey dates are non-working dates according to the Standard Base Calendar. May 30th is a non-working date that was specified on the Resource Calendar but not on the Standard Base Calendar. May 29th is a working day with non-standard working times. 





The View Bar is highlighted in green in this Gantt Chart view; the task table is highlighted in yellow; the Gantt chart is highlighted in blue.





Four pipefitters are available, but the maximum load is initially more than four. By splitting and delaying tasks, the load is never greater than four.
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